using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(.+)";
        string substitution = @"$1_$1_suffix";
        string input = @"A
B
C";
        
        Regex regex = new Regex(pattern);
        string result = regex.Replace(input, substitution);
    }
}