import Foundation
let pattern = #"(.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
A
B
C
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_$1_suffix"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)