#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http[s]?:\/\/)?([^\/\s]+\/)(.*)"
Local $sString = "http://video.google.co.uk:80/videoplay?docid=-7246927612831078230&hl=en#hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")