re = /(http[s]?:\/\/)?([^\/\s]+\/)(.*)/
str = 'http://video.google.co.uk:80/videoplay?docid=-7246927612831078230&hl=en#hello'
# Print the match result
str.match(re) do |match|
puts match.to_s
end