import re
regex = re.compile(r"(http[s]?:\/\/)?([^\/\s]+\/)(.*)")
test_str = "http://video.google.co.uk:80/videoplay?docid=-7246927612831078230&hl=en#hello"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")