using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"w|[ehmors]e|[^u]es|duc|[dn]y";
string input = @"lioness
hen
mare
cow
duck
sow
doe
ewe
goose
nanny
queen
princess
empress
duchess
marchioness
countess
baroness
baronetess
lady
dame
lion
rooster
stallion
bull
drake
boar
buck
ram
gander
billy
king
prince
emperor
duke
marquess
earl
baron
baronet
lord
knight";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}