// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)w|[ehmors]e|[^u]es|duc|[dn]y").unwrap();
let string = "lioness
hen
mare
cow
duck
sow
doe
ewe
goose
nanny
queen
princess
empress
duchess
marchioness
countess
baroness
baronetess
lady
dame
lion
rooster
stallion
bull
drake
boar
buck
ram
gander
billy
king
prince
emperor
duke
marquess
earl
baron
baronet
lord
knight";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}