package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)w|[ehmors]e|[^u]es|duc|[dn]y`)
var str = `lioness
hen
mare
cow
duck
sow
doe
ewe
goose
nanny
queen
princess
empress
duchess
marchioness
countess
baroness
baronetess
lady
dame
lion
rooster
stallion
bull
drake
boar
buck
ram
gander
billy
king
prince
emperor
duke
marquess
earl
baron
baronet
lord
knight`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}