const regex = /w|[ehmors]e|[^u]es|duc|[dn]y/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('w|[ehmors]e|[^u]es|duc|[dn]y', 'gm')
const str = `lioness
hen
mare
cow
duck
sow
doe
ewe
goose
nanny
queen
princess
empress
duchess
marchioness
countess
baroness
baronetess
lady
dame
lion
rooster
stallion
bull
drake
boar
buck
ram
gander
billy
king
prince
emperor
duke
marquess
earl
baron
baronet
lord
knight`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}