use strict;
my $str = 'lioness
hen
mare
cow
duck
sow
doe
ewe
goose
nanny
queen
princess
empress
duchess
marchioness
countess
baroness
baronetess
lady
dame
lion
rooster
stallion
bull
drake
boar
buck
ram
gander
billy
king
prince
emperor
duke
marquess
earl
baron
baronet
lord
knight';
my $regex = qr/w|[ehmors]e|[^u]es|duc|[dn]y/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}