#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\t ]*\/\*(?:.|\R)*?\*\/[\t ]*\R?)|(\/\/.*)"
Local $sString = "dsfgdfg" & @CRLF & _
"sgdsfg" & @CRLF & _
" //sfdfgg " & @CRLF & _
"" & @CRLF & _
"sfg //sfgdfg dfg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" /*sdf" & @CRLF & _
"hjhnkj" & @CRLF & _
"jlknlkn" & @CRLF & _
"lnln" & @CRLF & _
"" & @CRLF & _
"*/ " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"dsfsdf" & @CRLF & _
"*/" & @CRLF & _
"adfsdf" & @CRLF & _
"/*sdfsd*/" & @CRLF & _
"/**/" & @CRLF & _
"sdfgdfg" & @CRLF & _
"dfgdfgdf" & @CRLF & _
"gdfgdfg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")