package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\t ]*\/\*(?:.|\R)*?\*\/[\t ]*\R?)|(\/\/.*)`)
var str = `dsfgdfg
sgdsfg
//sfdfgg
sfg //sfgdfg dfg
/*sdf
hjhnkj
jlknlkn
lnln
*/
dsfsdf
*/
adfsdf
/*sdfsd*/
/**/
sdfgdfg
dfgdfgdf
gdfgdfg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}