import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\t ]*\\/\\*(?:.|\\R)*?\\*\\/[\\t ]*\\R?)|(\\/\\/.*)";
final String string = "dsfgdfg\n"
+ "sgdsfg\n"
+ " //sfdfgg \n\n"
+ "sfg //sfgdfg dfg\n\n\n\n"
+ " \n"
+ " /*sdf\n"
+ "hjhnkj\n"
+ "jlknlkn\n"
+ "lnln\n\n"
+ "*/ \n"
+ " \n"
+ " \n\n"
+ "dsfsdf\n"
+ "*/\n"
+ "adfsdf\n"
+ "/*sdfsd*/\n"
+ "/**/\n"
+ "sdfgdfg\n"
+ "dfgdfgdf\n"
+ "gdfgdfg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}