$re = '/([\t ]*\/\*(?:.|\R)*?\*\/[\t ]*\R?)|(\/\/.*)/';
$str = 'dsfgdfg
sgdsfg
//sfdfgg
sfg //sfgdfg dfg
/*sdf
hjhnkj
jlknlkn
lnln
*/
dsfsdf
*/
adfsdf
/*sdfsd*/
/**/
sdfgdfg
dfgdfgdf
gdfgdfg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);