re = /([\t ]*\/\*(?:.|\R)*?\*\/[\t ]*\R?)|(\/\/.*)/
str = 'dsfgdfg
sgdsfg
//sfdfgg
sfg //sfgdfg dfg
/*sdf
hjhnkj
jlknlkn
lnln
*/
dsfsdf
*/
adfsdf
/*sdfsd*/
/**/
sdfgdfg
dfgdfgdf
gdfgdfg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end