#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<table>.*<\/table>(?=\n*<div>)"
Local $sString = "<div>" & @CRLF & _
"<table></table>" & @CRLF & _
"<table><div>sdfgsdfbdcsbsdf<div></table>" & @CRLF & _
"<table><div>asdfasdgadfgsdf<div></table>" & @CRLF & _
"<div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")