using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<table>.*<\/table>(?=\n*<div>)";
string input = @"<div>
<table></table>
<table><div>sdfgsdfbdcsbsdf<div></table>
<table><div>asdfasdgadfgsdf<div></table>
<div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}