$re = '/<table>.*<\/table>(?=\n*<div>)/m';
$str = '<div>
<table></table>
<table><div>sdfgsdfbdcsbsdf<div></table>
<table><div>asdfasdgadfgsdf<div></table>
<div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);