const regex = /<table>.*<\/table>(?=\n*<div>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<table>.*<\\\/table>(?=\\n*<div>)', 'gm')
const str = `<div>
<table></table>
<table><div>sdfgsdfbdcsbsdf<div></table>
<table><div>asdfasdgadfgsdf<div></table>
<div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}