#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(([^,\s\)]+)(?:\s*,\s*([^,\s\)]+))*\)"
Local $sString = "someFunc(param)" & @CRLF & _
"" & @CRLF & _
"someFunc(param, param2)" & @CRLF & _
"" & @CRLF & _
"someFunc(param, param2, param3)" & @CRLF & _
"" & @CRLF & _
"someFunc(param, param2, param3, param4)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")