using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([^,\s\)]+)(?:\s*,\s*([^,\s\)]+))*\)";
string input = @"someFunc(param)
someFunc(param, param2)
someFunc(param, param2, param3)
someFunc(param, param2, param3, param4)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}