package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(([^,\s\)]+)(?:\s*,\s*([^,\s\)]+))*\)`)
var str = `someFunc(param)
someFunc(param, param2)
someFunc(param, param2, param3)
someFunc(param, param2, param3, param4)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}