import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(([^,\\s\\)]+)(?:\\s*,\\s*([^,\\s\\)]+))*\\)";
final String string = "someFunc(param)\n\n"
+ "someFunc(param, param2)\n\n"
+ "someFunc(param, param2, param3)\n\n"
+ "someFunc(param, param2, param3, param4)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}