package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]+\.[0-9]{2}`)
var str = `Order Details: item one 1 @ $33.99 $33.99 item two 100 @ $3.99 $399.00 item three 10 @ $333.99 $3339.90 Subtotal: 33333.99 Shipping: 10.27 Tax: 0.00 Total: 444444.26`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}