import Foundation
let pattern = #"[0-9]+\.[0-9]{2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Order Details: item one 1 @ $33.99 $33.99 item two 100 @ $3.99 $399.00 item three 10 @ $333.99 $3339.90 Subtotal: 33333.99 Shipping: 10.27 Tax: 0.00 Total: 444444.26"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)