import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+\\.[0-9]{2}";
final String string = "Order Details: item one 1 @ $33.99 $33.99 item two 100 @ $3.99 $399.00 item three 10 @ $333.99 $3339.90 Subtotal: 33333.99 Shipping: 10.27 Tax: 0.00 Total: 444444.26";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}