# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^\h+//gm;t' <<< "Hi!
My name is:
Bob
I am from the USA."