re = /(?m)^\h+/m
str = 'Hi!
My name is:
Bob
I am from the USA.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result