package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^\h+`)
var str = `Hi!
My name is:
Bob
I am from the USA.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}