$re = '/(?m)^\h+/m';
$str = 'Hi!
My name is:
Bob
I am from the USA.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;