# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<title>((?:(?!<\\/title>).)*)<\\/title>\s*<content>)((?:(?!<\\/content>).)*)/$1$2 $3/g;t' <<< "<xml>
<item>
<title>Title 1</title>
<content>Text 1</content>
</item>
<item>
<title>Title 2</title>
<content>Text 2</content>
</item>
</xml>"