const regex = /(<title>((?:(?!<\/title>).)*)<\/title>\s*<content>)((?:(?!<\/content>).)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<title>((?:(?!<\\\/title>).)*)<\\\/title>\\s*<content>)((?:(?!<\\\/content>).)*)', 'g')
const str = `<xml>
<item>
<title>Title 1</title>
<content>Text 1</content>
</item>
<item>
<title>Title 2</title>
<content>Text 2</content>
</item>
</xml>`;
const subst = `$1$2 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);