re = /(<title>((?:(?!<\/title>).)*)<\/title>\s*<content>)((?:(?!<\/content>).)*)/
str = '<xml>
<item>
<title>Title 1</title>
<content>Text 1</content>
</item>
<item>
<title>Title 2</title>
<content>Text 2</content>
</item>
</xml>'
subst = '$1$2 $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result