import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<title>((?:(?!<\\/title>).)*)<\\/title>\\s*<content>)((?:(?!<\\/content>).)*)";
final String string = "<xml>\n"
+ " <item>\n"
+ " <title>Title 1</title>\n"
+ " <content>Text 1</content>\n"
+ " </item>\n"
+ " <item>\n"
+ " <title>Title 2</title>\n"
+ " <content>Text 2</content>\n"
+ " </item>\n"
+ "</xml>";
final String subst = "$1$2 $3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}