# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<title>((?:(?!<\/title>).)*)<\/title>\s*<content>)((?:(?!<\/content>).)*)"
test_str = ("<xml>\n"
" <item>\n"
" <title>Title 1</title>\n"
" <content>Text 1</content>\n"
" </item>\n"
" <item>\n"
" <title>Title 2</title>\n"
" <content>Text 2</content>\n"
" </item>\n"
"</xml>")
subst = "$1$2 $3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.