#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)begin(?:(?!begin).)*TOKEN_456.*?end"
Local $sString = "someText" & @CRLF & _
"" & @CRLF & _
"begin" & @CRLF & _
" .someMethod()" & @CRLF & _
" .doSomething(TOKEN_123)" & @CRLF & _
" .someMethod()" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"begin" & @CRLF & _
" .someMethod()" & @CRLF & _
" .doSomething(TOKEN_456)" & @CRLF & _
" .someMethod()" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"begin" & @CRLF & _
" .someMethod()" & @CRLF & _
" .doSomething(TOKEN_789)" & @CRLF & _
" .someMethod()" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"more Text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")