import Foundation
let pattern = #"begin(?:(?!begin).)*TOKEN_456.*?end"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
someText
begin
.someMethod()
.doSomething(TOKEN_123)
.someMethod()
end
begin
.someMethod()
.doSomething(TOKEN_456)
.someMethod()
end
begin
.someMethod()
.doSomething(TOKEN_789)
.someMethod()
end
more Text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)