import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "begin(?:(?!begin).)*TOKEN_456.*?end";
final String string = "someText\n\n"
+ "begin\n"
+ " .someMethod()\n"
+ " .doSomething(TOKEN_123)\n"
+ " .someMethod()\n"
+ "end\n\n"
+ "begin\n"
+ " .someMethod()\n"
+ " .doSomething(TOKEN_456)\n"
+ " .someMethod()\n"
+ "end\n\n"
+ "begin\n"
+ " .someMethod()\n"
+ " .doSomething(TOKEN_789)\n"
+ " .someMethod()\n"
+ "end\n\n"
+ "more Text";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}