re = /begin(?:(?!begin).)*TOKEN_456.*?end/i
str = 'someText
begin
.someMethod()
.doSomething(TOKEN_123)
.someMethod()
end
begin
.someMethod()
.doSomething(TOKEN_456)
.someMethod()
end
begin
.someMethod()
.doSomething(TOKEN_789)
.someMethod()
end
more Text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end