# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?![\s'-])(?:[\s'-]{0,1}[\p{L}])+$//img;t' <<< "Masion
Délire
Vértige
Ma-Maison-Heueuse
Libre de Vivre
Combat d'El Toro
Mire er
L'école des Mimosa
sephorù
Владимир
Владими ладим
sephorù
中華人民共和國
Nippon-koku ou Nihon-koku
日本国
جزيرة العرب
Sephora55
55789
?yuiy
(hjk)
sephoraö
"