use strict;
my $str = 'Masion
Délire
Vértige
Ma-Maison-Heueuse
Libre de Vivre
Combat d\'El Toro
Mire er
L\'école des Mimosa
sephorù
Владимир
Владими ладим
sephorù
中華人民共和國
Nippon-koku ou Nihon-koku
日本国
جزيرة العرب
Sephora55
55789
?yuiy
(hjk)
sephoraö
';
my $regex = qr/^(?![\s'-])(?:[\s'-]{0,1}[\p{L}])+$/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";