using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![\s'-])(?:[\s'-]{0,1}[\p{L}])+$";
string substitution = @"";
string input = @"Masion
Délire
Vértige
Ma-Maison-Heueuse
Libre de Vivre
Combat d'El Toro
Mire er
L'école des Mimosa
sephorù
Владимир
Владими ладим
sephorù
中華人民共和國
Nippon-koku ou Nihon-koku
日本国
جزيرة العرب
Sephora55
55789
?yuiy
(hjk)
sephoraö
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}