# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?![\s'-])(?:[\s'-]{0,1}[\p{L}])+$"
test_str = ("Masion\n"
"Délire\n"
"Vértige\n"
"Ma-Maison-Heueuse\n"
"Libre de Vivre\n"
"Combat d'El Toro\n"
"Mire er\n"
"L'école des Mimosa\n"
"sephorù\n"
"Владимир\n"
"Владими ладим\n"
"sephorù\n"
"中華人民共和國\n"
"Nippon-koku ou Nihon-koku\n"
"日本国\n"
"جزيرة العرب\n"
"Sephora55\n"
"55789\n"
"?yuiy\n"
"(hjk)\n"
"sephoraö\n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.