#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^(?![\s'-])(?:[\s'-]{0,1}[\p{L}])+$"
Local $sString = "Masion" & @CRLF & _
"Délire" & @CRLF & _
"Vértige" & @CRLF & _
"Ma-Maison-Heueuse" & @CRLF & _
"Libre de Vivre" & @CRLF & _
"Combat d'El Toro" & @CRLF & _
"Mire er" & @CRLF & _
"L'école des Mimosa" & @CRLF & _
"sephorù" & @CRLF & _
"Владимир" & @CRLF & _
"Владими ладим" & @CRLF & _
"sephorù" & @CRLF & _
"中華人民共和國" & @CRLF & _
"Nippon-koku ou Nihon-koku" & @CRLF & _
"日本国" & @CRLF & _
"جزيرة العرب" & @CRLF & _
"Sephora55" & @CRLF & _
"55789" & @CRLF & _
"?yuiy" & @CRLF & _
"(hjk)" & @CRLF & _
"sephoraö" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)