# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\s*(?:,|\bor\b))+\s*/\n/gmi;t' <<< "one,two or three , four or five or , or six , oR , seven, ,,or, ,, eight or qwertyor orqwerty,"