import Foundation
let pattern = #"(?:\s*(?:,|\bor\b))+\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"one,two or three , four or five or , or six , oR , seven, ,,or, ,, eight or qwertyor orqwerty,"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)