// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:\s*(?:,|\bor\b))+\s*").unwrap();
let string = "one,two or three , four or five or , or six , oR , seven, ,,or, ,, eight or qwertyor orqwerty,";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}