using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s*(?:,|\bor\b))+\s*";
string substitution = @"\n";
string input = @"one,two or three , four or five or , or six , oR , seven, ,,or, ,, eight or qwertyor orqwerty,";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}