use strict;
my $str = 'one,two or three , four or five or , or six , oR , seven, ,,or, ,, eight or qwertyor orqwerty,';
my $regex = qr/(?:\s*(?:,|\bor\b))+\s*/mip;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";