using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http:\/\/(?!www\.)\w+\.\w+(?:\/.*)?$";
string input = @"http://www.host.com
http://host.com
www.host.com
host.com
http://'anything.'host.com
http://www.host.com
http://sub.host.com
http://host.com/asdsdad";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}